Animacje przycisku

W tym przykładzie stworzysz przycisk, który będzie reagować na akcje myszki, jak najechanie nad jego obszar czy kliknięcie. Nauczysz się:

  1. Aby uruchomić program kliknij dwukrotnie na ikonie Alligator Flash Designer na pulpicie.
  2. Wciśnij Testuj jeśli masz wersję testową programu.
  3. Wybierz Pusty projekt Flash i kliknij OK.
  4. Uruchomi się program.
  5. Z menu Ramka wybierz Rozmiar ramki.
  6. Wpisz 200 jako "Szerokość" i 200 jako "Wysokość". Kliknij OK aby potwierdzić.
  7. Z menu Ramka wybierz Czas Ramki.
  8. Zaznacz Stop i kliknij OK.
  9. Z menu Ramka wybierz Wstaw i kliknij OK. Nowa ramka pojawi się jako Frame 2
  10. Z menu Film wybierz Dodaj Matrycę. Nowa ramka pojawi się jako Master Frame (1)
  11. Z menu Ramka wybierz Kolor Tła.
  12. Otworzy się okno wyboru koloru.
  13. Wybierz ulubiony kolor. Możesz np.: kliknąć "Kolory standardowe" i wybrać dowolny kolor z okienka. Kliknij OK aby zmienić kolor tła.
  14. Wybierz narzędzie "Elipsa":
  15. Narysuj elipsę - najedź kursorem myszki nad obszar animacji, kliknij i przytrzymaj wciśnięty lewy przycisk myszy.
  16. Przejdź do ramki Frame 2 (klawiszem PgDown, lub klikając w oknie "Lista ramek")
  17. Wybierz narzędzie "Tekst":
  18. Kliknij w dowolnym miejscu wewnątrz elipsy.
  19. Pojawi się okno edycji tekstu.
  20. Wpisz tekst "Kliknij mnie" i kliknij OK.
  21. Z menu Widok wybierz Pierwsza ramka aby przejść do ramki-matrycy.
  22. Upewnij się że elipsa jest zaznaczona (zaznacz jeżeli potrzeba za pomocą wskaźnika).
  23. Z menu Akcja wybierz Najechanie .
  24. W akcji "Najechania" wybierz "Skok do ramki", i wybierz "Frame 2". Kliknij OK.
  25. Z menu Akcja wybierz Wyjechanie.
  26. W akcji "Wyjechania" zaznacz "Skok do ramki", i wybierz "Frame 1". Kliknij OK.
  27. Z menu Akcja wybierz Kliknięcie.
  28. W akcji "Kliknięcia" wybierz "Otwórz URL".
  29. Wpisz adres swojej strony (np "http://www.selteco.pl"). Adres musi zaczynać się od "http://". Kliknij OK.
  30. Wciśnij F9 i obserwuj swoją animację. Najedź kursorem myszki nad obszar elipsy.
  31. Wciśnij kombinację klawiszy "Alt+F4" aby opuścić podgląd.
  32. Z menu Plik wybierz Eksport Flash SWF.
  33. Zmień katalog na "Pulpit".
  34. Wpisz "przycisk" jako nazwę pliku i kliknij na przycisk Zapisz.
  35. Z menu Plik wybierz Eksport strony HTML, kliknij OK aby pozostawić domyślne ustawienia.
  36. Strona pojawi się w okienku przeglądarki internetowej. Przewiń stronę niżej aby zobaczyć kod HTML.
  37. Aktywuj ponownie program Selteco Alligator Flash Designer i wybierz Koniec z menu Plik. Kliknij "Nie" w oknie dialogowym z zapytaniem o zapisanie dokonanych zmian.