Obiekty i Kompozycja

Każda ramka zawiera jeden lub więcej obiektów.

Kształty, Obrazki, Tekst, Przyciski (buttony), Klipy animacji (sprites)

Użyj narzędzia "Wskaźnik" by zaznaczyć, przesunąć, wyrównać lub powielić obiekty.

Aby zaznaczyć obiekt kliknij na nim przy pomocy narzędzia "Wskaźnik". Aby odznaczyć kliknij na tle ramki.

Zaznaczanie 2 lub więcej obiektów

Wybierz narzędzie "Wskaźnik" i przeciagając kursor myszki mając wciśniety lewy klawisz myszki narysuj prostokąt wokół obiektów, które chcesz zaznaczyć.

lub

By zaznaczyć równocześnie wiele obiektów przytrzymaj klawisz Shift i kliknij na obiekt, który chcesz dodać do (lub by odznaczyć, gdy zaznaczony) zaznaczonych.

Powielanie obiektów

By powielić obiekt(y) przytrzymaj klawisz Ctrl i przesuń obiekt.

lub

Zaznacz obiekt i wybierz "Edycja" > "Powiel". Ustaw pozycję nowego obiektu i kliknij OK. Zdefiniuj ile razy ma być powielony obiekt aby stworzyć więcej niż jedną kopię.

Ustawianie Obiektów

Można przesuwać obiekty przy użyciu narzędzia "Wskaźnik". Obserwuj pasek stanu na dole okna programu aby znać aktualną pozycję x, y obiektu na animacji.

Dokładne pozycjonowanie

Zaznacz obiekty i użyj klawiszy strzałek aby przesuwać obiekty o 1 piksel w lewo, w górę, w dół i w prawo. Przytrzymując wciśniety klawisz Shift i używając klawiszy strzałek możesz przesuwać obiekty szybciej, ze skokiem co 10 pikseli, a nie co 1 piksel.

Użyj polecenia "Edycja" > "Przesuń do" aby umieścić obiekt na dokładnej pozycji x (pozioma) i y (pionowa). Lewy górny róg animacji ma wartości 0,0.

Użyj polecenia "Edycja" > "Przesuń o" aby przesunąć obiekt o x (prawa) i y (dół) pikseli.

Wyrównywanie obiektów

Aby wyrównać obiekty względem obszaru animacji

zaznacz obiekt i wybierz polecenie wyrównania z menu "Edycja" > "Wyrównaj"

Aby wyśrodkować obiekt w pionie i poziomie względem obszaru animacji

zaznacz obiekt i wybierz polecenie "Edycja" > "Wyrównaj" > "Wycentruj na stronie"

Użyj przycisków-skrótów z prawej strony okna programu aby wyrównywać obiekty do dowolnej krawędzi.

Ustawianie prowadnic

kliknij prawym na obszarze animacji i z rozwiniętego menu wybierz "Wstaw linijkę poziomą" lub "Wstaw linijkę pionową". Aby wstawić 2 linijki na środku animacji wybierz "Wstaw" > "Linijki"

Przemieszczanie prowadnic

wybierz narzędzie "Wskaźnik" i przenieś linijkę lub kliknij na niej prawym przyciskiem myszy i wybierz komendę "Przesuń".

Usuwanie prowadnic

kliknij prawym na linijce i wybierz opcję "Skasuj".

Skalowanie obiektów

Zaznacz obiekt i wybierz z menu "Obiekt" > "Rozciągnij". Wpisz nowe wartości wielkości obiektu. Zaznacz "Proporcjonalne" aby zadać nową wielkość z zachowaniem proporcji.

lub

Zaznacz obiekt i przeciągnij któryś z uchwytów na brzegach lub na rogach obiektu.

lub

Zaznacz obiekt i użyj polecenia "Edycja" > "Przesuń do" i zmień wartości szerokości i wysokości.

Obracanie obiektów

Aby ustawić kąt obrotu obiektu, w jakim zostanie wyeksportowany do Flash Playera wybierz "Obiekt" > "Obróć" > "Obróć o dowolny kąt". Wykonany obrót nie będzie widoczny w oknie pracy z animacją w programie (dopiero w oknie podglądu)

Aby obrócić obiekt w celu dalszej edycji np.: obrazek lub krzywą, zaznacz obiekt i wybierz "Obiekt" > "Obróć". Ta funkcja działa tylko z obrazkami bitmapowymi i kształtami.

Odbicie lustrzane obiektów

Zaznacz obiekt i i wybierz z menu "Obiekt" > "Właściwości wyświetlania". Zaznacz opcje "Odbij w poziomie" lub "Odbij w pionie". Odbicie lustrzane jest eksportowane do Flash Playera, jednak jest niewidoczne w trybie edycji animacji.

Aby wykonać odbicie lustrzane bitmap lub krzywych, zaznacz obiekt i wybierz z menu "Obiekt" > "Obrót" > "Odbij w poziomie" (lub "Odbij w pionie"). Tylko obrazki bitmapowe i kształty mogą być odbijane w poziomie/w pionie.

Grupowanie obiektów

Zgrupowane obiekty można przemieszczać razem jak jeden obiekt. Aby zgrupować obiekty, zaznacz 2 lub więcej obiektów i wybierz "Edycja" > "Grupuj".

Grupa może być zagnieżdżona w innej grupie - grupa może być częścią innej grupy.

Aby rozgrupować obiekty z danej grupy, zaznacz grupę i wybierz "Edycja" > "Rozgrupuj". Ustawienia przypisane danej grupie, jak akcje myszki, zostaną utracone po rozgrupowaniu.

Kolejność ułożenia i zakrywanie

Kolejność ułożenia definiuje jak obiekty zakrywają się nawzajem. Obiekty na wierzchu zakrywają obiekty pod spodem.

Przemieszczanie obiektów pod spód

Zaznacz 1 lub więcej obiektów i wybierz "Edycja" > "Pod spód". Obiekt zostanie ukryty pod innymi obiektami.

Umieszczanie obiektów na wierzchu

Zaznacz 1 lub więcej obiektów i wybierz "Edycja" > "Na wierzch". Obiekt zostanie umieszczony nad pozostałymi obiektami.

Master Frames (ramki-tła - matryce) i Obiekty

Aby stworzyć ramkę ze współdzielonymi obiektami wybierz"Film" > "Dodaj matrycę" i umieść wspólne obiekty na ramce Master Frame. Obiekty z matrycy pojawią się pod innymi obiektami na pozostałych ramkach. Aby przenieść obiekty z matrycy na inną warstwę, zaznacz wybrane obiekty, wybierz z menu "Obiekt" > "Właściwości wyświetlania" i zmień opcję Warstwa z rozwijanej listy na "Layer 1" lub którąkolwiek warstwę będącą nad warstwą "Base layer".