Eksport filmów Flash do pliku SWF

Program Alligator Flash Designer eksportuje animacje flash do standardowego formatu SWF, który może być odtwarzany w każdej przeglądarce www z plug-inem Flash, jak np.: Internet Explorer lub FireFox.

Plik SWF zawiera dane (zdjęcia, grafikę, dźwięk) dla plug-inu Flash Player
Plik HTML powoduje załadowanie i wyświetlenie pliku SWF
SFD to projekt źródłowy programu Alligator
JS opcjonaly plik JavaScript który pomija ostrzeżenie "click to activate this control" w Internet Explorer

Eksport testowej strony

Należy wybrać "Plik" > "Eksport strony HTML", wybrać nazwę dla pliku SWF i wybrać opcję strony testowej: "Przykładowa strona...".

Eksport strony WWW

Należy wybrać "Plik" > "Eksport strony HTML", wybrać nazwę dla pliku SWF i wybrać opcję strony www: "Pusta strona...".

Wstawianie animacji Flash do istniejącej strony.

Jeżeli edytor nie posiada wbudowanej funkcji wstawiania animacji Flash należy wkleić kod HTML na stronę w następujący sposób:

  1. Eksport pliku SWF
    Wybierz polecenie "Eksport Flash SWF" z głównego menu programu "Plik". Zapisz plik w tym samym folderze, w którym znajduje się Twoja strona i pliki HTML.
  2. Wygenerowanie kodu HTML
    Wybierz polecenie "Plik" > "Pokaż kod HTML" i kliknij "Kopiuj".

  3. Wklejenie kodu HTML
    Otwórz w swoim edytorze HTML plik strony i wklej skopiowany kod.
  4. Podgląd
    Zobacz swoją stronę w przeglądarce aby się upewnić, że animacja jest widoczna.
  5. Wgranie na serwer
    Umieść na serwerze oba pliki: plik HTML i plik SWF.
W przypadku gdy została użyta opcja wstawienia pliku z użyciem kodu JavaScript należy także wgrać plik swfobject.js

Wgrywanie plików na serwer www

Pliki SWF i HTM można wgrać przy pomocy każdego klienta FTP np. Selteco FTP (http://www.selteco.pl/pobierz/sftppl.exe)

Eksport pliku BAT w pełnym oknie

Należy wybrać "Plik" > "Eksport strony HTML", wybrać nazwę dla pliku SWF i wybrać opcję: "Plik BAT dla trybu Kiosk". Aby zamknąć okno podglądu w trybie pełnoekranowym należy wcisnąć ALT+F4.

Przycisk zamykania okna

Aby utworzyć przycisk zamykania okna pełnoekranowego należy wstawić przycisk (np.: komendą "Wstaw" > "Symbol" i wybrać symbol ) a następnie przypisać akcję "Obiekt" > "Akcje" > "Kliknięcia", zaznaczyć Otwórz URL i wpisać zamiast "http://":

javascript:window.opener=self;window.close();

Zobacz również: Używanie programu Alligator Flash Designer z programem Microsoft FrontPage
(www.selteco.com - strona w języku angielskim)